Jump to content

macOS High Sierra - Camera not rendering


Recommended Posts


I'm having issues after upgrading to High Sierra. I downloaded a fresh copy of EIAS9.1. Moved it to the Desktop, plugged in the dongle, launched both Animator and Camera. Animater triggered the serial number insertion which I did and was accepted. Camera alone starts without complaining. I can open any project and work in animator but if I try to render, when camera opens (with a task this time as opposed to not having to do anything), I get a MacOS modal dialog with:

“Camera_64” can’t be opened because the identity of the developer cannot be confirmed. 

And then an EI Modal Dialog with:

An OS exception occurred inside Camera.

I'm not sure this issue is related to high sierra specifically. It could just be a permission issue that I missed. Can anyone help me with this?

Link to comment
Share on other sites

Ok I fidgeted a little more with the issue. It's related to the MacOS gatekeeper and the need for developers to sign their code.

Obviously I forgot to mention that I HAD already disabled the gatekeeper before attempting to render.

Disabling the gatekeeper was previously available as a switch in System Preferences > Security & Privacy > General. Not anymore... to completely disable the gatekeeper you need to use the spctl command line tool.

Unfortunately, even with a disabled keeper the app still reports that Camera_64 can't be run. That's weird. I re-enabled the keeper and tried to assess Camera_64 from the command line and I got: “Camera_64” rejected (the code is valid but does not seem to be an app).

Googling this I found other developers hitting the same wall when trying to distribute command line tools. Some of these just solved the issue by creating a fake app bundle around their tool and then allowing/signing that one. Not an option for me to try because I assume regular Camera expects Camera_64 to be in that specific place.

Can you folks on the dev team come up with a temporary workaround.

Thank you.

Link to comment
Share on other sites

So... after some more playing around and a lot of help from Tomas I found out what was wrong. I'm writing it here shall anyone happen to have my same issue. The problem is related to Apple's Gatekeeper that allows or denies unsigned code to be executed. Up until before Sierra and High Sierra, users had the option of selecting "Allow from anywhere". That option is missing now. My specific problem was that I had tried to launch Camera and/or Camera_64 before disabling the gatekeeper. This had probably created a blocking rule that was stopping Camera_64 from starting. So if you happen to have my same problems do these things:

1. Download a fresh copy of EIAS. No you can't use the one already installed.

2. Open your terminal and type "sudo spctl --master-disable" (without the quotes). You will be asked for your password.

3. Open System Preferences and go into the Security & Privacy panel. Unlock the panel with your password and switch the "Allow apps downloaded from" setting back and forth to App Store and then back to Anywhere. This will trigger a confirmation dialog. If you don't see the "Anywhere" option it means step 2 did not work. Try again.

4. Only now, attempt to launch any EIAS app. The rest should be straightforward.


  • Like 1
Link to comment
Share on other sites

  • 9 months later...

Hello RDM or Tomas,


I've just installed High Sierra on my MacBook Pro and I've followed steps 1 to 4 of the above procedure. (I get the «anywhere» in step 3).

Still cannot launch Animator. I've tried to reinstall the OSX Universal Dongle Installer but get a failed message.

Please help!


Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...